Jump to content
270soft Forum
Dayum

User Scenarios Will Not Work AT ALL on my MacBook!

Recommended Posts

Hi, 

I play PMI UK on my MacBook, and I have been unable to play any user scenarios whatsoever. The few pre-loaded scenarios work, but if I even slightly edit duplicates of those, or play downloaded user scenarios, then I get error codes, and am unable to play. 

Any suggestions?

Share this post


Link to post
Share on other sites

"if I even slightly edit duplicates of those, or play downloaded user scenarios, then I get error codes, and am unable to play."

Are you using the Editor to edit them? Do you get error codes while editing them, or afterwards when you try to start a game with them?

Share this post


Link to post
Share on other sites
10 minutes ago, admin_270 said:

Are you using the Editor to edit them? Do you get error codes while editing them, or afterwards when you try to start a game with them?

Yes, I am using the Editor to edit them. I get error codes when I am playing them, usually within the first two or so turns. 

Share this post


Link to post
Share on other sites
1 hour ago, admin_270 said:

What does the first error you receive say?

@admin_270 I've attached some screenshots of the error codes/messages that appear.

Screenshot 2019-03-27 at 19.28.03.png

Screenshot 2019-03-27 at 19.28.21.png

Screenshot 2019-03-27 at 19.28.33.png

Share this post


Link to post
Share on other sites
3 minutes ago, admin_270 said:

The best way for me to try to figure out what is happening is to send a compressed (zipped) copy of the campaign to me. You can e-mail it to the address on https://270soft.com or post it here if you'd like.

I'll post it here. 

The campaign is a role-play scenario based on The Sims 4 (nerdy, I know. :P)

 

Holston Forest Local Elections - May 2018.zip

Share this post


Link to post
Share on other sites
28 minutes ago, lolandrewlmao said:

I have the same issue. I'd say 75% of user scenarios give me the TGameEngine error code at the same point every game.

It is really frustrating! I don't know if it's a bug or something, but it really needs to be fixed because I basically can't play user scenarios.

@admin_270

Share this post


Link to post
Share on other sites

@admin_270 I've just tried playing another campaign on my MacBook, and this error message appeared towards the end of the campaign. 

At this point, the game is basically unplayable. 

 

Screenshot 2019-03-31 at 21.14.58.png

Screenshot 2019-03-31 at 21.15.07.png

Share this post


Link to post
Share on other sites

@Dayum

The cause of the campaign crashing is there is an issue 'devolution' that doesn't have a correlate issue positions for any given party (or leader for that matter).

So somehow, a discrepancy is being created.

Can you try editing a campaign without changing the issues, and tell me if it causes a problem?

Share this post


Link to post
Share on other sites
4 hours ago, admin_270 said:

@Dayum

The cause of the campaign crashing is there is an issue 'devolution' that doesn't have a correlate issue positions for any given party (or leader for that matter).

So somehow, a discrepancy is being created.

Can you try editing a campaign without changing the issues, and tell me if it causes a problem?

@admin_270 I'm still getting the same error messages. 

Share this post


Link to post
Share on other sites

@admin_270 After making sure everything else was working fine, I think the problem is with the political issues. I haven't made any changes to the issues, but when I play the game I still get the same error message re. the issues. 

It's just really frustrating. :( 

Share this post


Link to post
Share on other sites

@admin_270 Is there anything I can myself to resolve this error?

Quote

error in TIssues::GetRandomWeighted ()

(e.g. is it just a political issue that I could delete?)

Share this post


Link to post
Share on other sites

@Dayum

Like I said, the problem in the campaign in question had to do with a devolution issue. So, you have to start with a new campaign. Use as a source an official campaign. Save it without making any changes. See if that works first.

Share this post


Link to post
Share on other sites
22 minutes ago, admin_270 said:

@Dayum

Like I said, the problem in the campaign in question had to do with a devolution issue. So, you have to start with a new campaign. Use as a source an official campaign. Save it without making any changes. See if that works first.

@admin_270 I've just used the official 2017 campaign, and saved it; I made no changes to the campaign whatsoever, and it seemed to be working okay. However, if I do anything to any of the regions/constituencies/parties/leaders, it corrupts the campaign and makes it unplayable in one way or another. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...