Jump to content
270soft Forum

Recommended Posts

@admin_270

Why did you arbitrarily change the national and regional flag proportions between PM4E and PMI? Was there a real good reason for that? You slipped it in somewhere, and I just noticed it now. I have a HUGE pile of flags, current and historic, from various nations and polities, waiting to be used in various PMI scenarios, but they're STILL in PM4E size proportions. That feels like an unnecessary kick in the butt...

Share this post


Link to post
Share on other sites
On ‎7‎/‎29‎/‎2018 at 3:40 PM, Patine said:

@admin_270

Why did you arbitrarily change the national and regional flag proportions between PM4E and PMI? Was there a real good reason for that? You slipped it in somewhere, and I just noticed it now. I have a HUGE pile of flags, current and historic, from various nations and polities, waiting to be used in various PMI scenarios, but they're STILL in PM4E size proportions. That feels like an unnecessary kick in the butt...

It's almost been a week, and @admin_270 hasn't even acknowledged this thread....

Share this post


Link to post
Share on other sites

@admin_270 Okay, this problem seems to affect map images too. I recently sent @vcczar a map that worked perfectly well in a PM4E2008 scenario, but fails to work in PMI. I tested several maps I have that worked perfectly in PM4E2008 by importing them into CI and PMI, and was told "this image was no selectable regions," and then failure to load. These map are of the same dimensions asked for, and have all regions surrounded by true black borders, but that doesn't seem to matter. Somewhere along the line, an arbitrary alteration was made to the specs of the maps and flags that would be recognized, and I can't find any announcement of this anywhere on this forum, or in the update notes for the game updates for PI, PMI, or CI. This effectively makes my VERY large collection of flag and map images potentially mostly useless without EVEN more endless work updating them all. The question is, were these changes necessary, why were they made, and is there any good reason they can't be undone?

Share this post


Link to post
Share on other sites

76 x 57 are the dimensions from Prime Minister Forever - Canada 2008, and those are the same with President Infinity.

It might be a different problem. Can you post the images in question here (in a compressed folder)?

Share this post


Link to post
Share on other sites
1 minute ago, admin_270 said:

76 x 57 are the dimensions from Prime Minister Forever - Canada 2008, and those are the same with President Infinity.

It might be a different problem. Can you post the images in question here (in a compressed folder)?

What really got me at first was that I made the flag in question for an old Alberta 1935 scenario by Alberta Premier Forever 2008 (essentially, identical game engine to PM4E2008), and I was trying to do a new version by PMI Canada. I tried to import the exact same I used successfully in old Premier Forever 2008 game, right from it's regions folder directly, and it said the proportions were incompatible. I then got this with other random test flags that had worked fine in PM4E2008, P4E2008, and K4E scenarios. Then it started refusing to recognize maps. Could my Infinity game editors be corrupted somehow?

Share this post


Link to post
Share on other sites

I recommend taking the flag files in question, putting them in a compressed folder, and posting here so I can look at them.

Share this post


Link to post
Share on other sites

And these were the two maps that were not recognized as having 'any selectable regions" AT ALL and just failed to load.

map.bmp

Share this post


Link to post
Share on other sites

@Patine You can mass-reszie via python.

Share this post


Link to post
Share on other sites

@admin_270 Okay, I've figured out the issue with the maps and why they were behaving like, but now I've come across a REAL persnickety problem with the editor, at least the CI one - I haven't checked this out on the PI or PMI one yet.

When I switch from the main menu of the editor to do a specific aspect, like regions, leaders, parties, etc., and then attempt to return to the main menu, which requires closing the submenu or the feature in question, the main menu of the editor immediately minimizes onto my taskbar tray, and nothing I do can restore or maximize it - I literally have to cntrl+alt+del and then manually shut it down every time. THAT needs to be fixed!

Share this post


Link to post
Share on other sites

You are saying if you are at the Editor screen, you click the Regions button, then click the Close (top right) button on the Regions screen, the whole program minimizes?

Share this post


Link to post
Share on other sites
34 minutes ago, admin_270 said:

You are saying if you are at the Editor screen, you click the Regions button, then click the Close (top right) button on the Regions screen, the whole program minimizes?

Yes, and is unable to be restored or maximized - it has to be shut down on the Task Manager - and all unsaved progress (such as that just done in the Regions submenu) is lost.

Share this post


Link to post
Share on other sites
39 minutes ago, admin_270 said:

You are saying if you are at the Editor screen, you click the Regions button, then click the Close (top right) button on the Regions screen, the whole program minimizes?

@admin_270 I think this is worthy of a hotfix.

Share this post


Link to post
Share on other sites
Just now, admin_270 said:

@Patine,

Do you have other programs open on the desktop at the same time?

I don't seem to have this issue. Try reinstalling @Patine, this stuff happens on occasion for me it was with Kaspersky.

Share this post


Link to post
Share on other sites
6 hours ago, NYrepublican said:

I don't seem to have this issue. Try reinstalling @Patine, this stuff happens on occasion for me it was with Kaspersky.

No, that didn't fix it. :(

Share this post


Link to post
Share on other sites
Just now, Patine said:

No, that didn't fix it. :(

Can you please get it on video and post here so @admin_270 or I can try to replicate it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×