Jump to content
270soft Forum
Madar Max

Problem with "invalid floating point" and "list index out of bounds"

Recommended Posts

Hi everyone,

I am currently facing a problem which I think is pretty common, but I couldn't find an answer to it while searching on this forum, so please excuse me if this was already asked and/or solved.

I am making a scenario, and it was working fine until I changed the dates of all the primaries (32 regions, 13 parties... yes, that's a lot). Now when I'm playing my scenario, I have the "invalid floading point" message (and the "list index out of bounds" message if I insist on trying to keep on playing) after some months (the date when the problems occurs is not the same from one party to another, which is even more annoying).

I couldn't find anything wrong about the new dates I chose for the primaries, so I cannot find where the problem could come from.

What could explain this situation, and if the problem cannot be solved on this very topic, who should I contact to fix it?

Thank you everyone, and please excuse my possible English mistakes. ^^

Share this post


Link to post
Share on other sites

I am not sure what may be the problem. I'm guessing you have checked that all dates are within the campaign time period. It is probably best to send the scenario via email to myself and others, to find out the problem. Use Winzip or Winrar (I have both), zip your scenario file (add to zip file)and send it to: treasurerofthepc@yahoo.com.

Share this post


Link to post
Share on other sites

I re-checked all the dates and I found two mistakes. I corrected them, I re-re-checked, everything is fine now about the dates, and the problem is still here... :-/

Share this post


Link to post
Share on other sites

Hi. I'm facing a similar problem, "list index out of bounds" error. I changed any data but only add some new candidated, is it possible it's too much of them?

Share this post


Link to post
Share on other sites

Try this: Did you intend to have a debate in the primaries? There is no date for a primaries debate in the scenario file, but you have entered 2 party id's to take part in one. The other date is for the general election debate.

Share this post


Link to post
Share on other sites

Hi. I'm facing a similar problem, "list index out of bounds" error. I changed any data but only add some new candidated, is it possible it's too much of them?

How many candidates do you have? I believe 32 is the most that can be used.

Share this post


Link to post
Share on other sites

Try this: Did you intend to have a debate in the primaries? There is no date for a primaries debate in the scenario file, but you have entered 2 party id's to take part in one. The other date is for the general election debate.

There was indeed a date for a general election debate that shouldn't have been there. I deleted it and it did not solve the problem.

However, I absolutely don't remember intending to have a debate in the primaries, and as you said, there is no date for such a debate.

Share this post


Link to post
Share on other sites

Some of the dates in the political units file, under "general" come under a 2008 date. Try changing the date within your time period to see if that works.

Share this post


Link to post
Share on other sites

It still doesn't work. :(

However, I noticed some interesting thing. While trying to locate the problem, I found out that it actually comes from the "PS" party. When all its candidates are off, the game works fine.

Then here is what is really strange. There are three candidates that are on initially : Ségolène Royal, Dominique Strauss-Kahn and Laurent Fabius. If I add a candidate for this party, the game works. If I put Strauss-Kahn or Fabius off, and replace them by another candidate, it doesn't work, while it works if Royal is replaced.

If I put any of these three off and do not add another candidate, it works.

If I put the UMP candidates off, and let the three PS candidates, it doesn't work, but the bug seems to appear later in the game.

All of this is really strange. Could there be a rational explanation to that?

Share this post


Link to post
Share on other sites

I haven't figured it out yet, but I have noticed when you go through the primaries campaign, it finishes at that, no presidential election comes up. Also, over 200,000 delegates for the UMP and PS parties. Does anyone else know if that might be too much?

Share this post


Link to post
Share on other sites

No presidential election comes up? It's weird, because this part works perfectly well when I go through the primaries campaign...

Share this post


Link to post
Share on other sites

No sorry, the presidential election part is OK. It seems the error only happens when Royal is involved, but 1-on-1 in the PS primaries, it's OK. Can you re-check Royale's profile again? I know you see things differently on Campaigns Forever, all I see is codes.

Share this post


Link to post
Share on other sites

I'll try find a solution but I may have to consult with other members who have more knowledge of the PFE + P format/coding. It's a really well-presented scenario, and I'd hate it to go to waste.

Share this post


Link to post
Share on other sites

I just got your e-mail, Treasurer (I've been locked out of my e-mail for over a week). Sometimes work in Campaigns Forever just inexplicably gets corrupted. Try this: First (and this is very important), deselect all veep choices for Royal. Then delete her and make her again from scratch. Do this for any other PS candidates who are causing problems. It's important to deselect veeps first; if they aren't, it causes other errors for some reason.

Share this post


Link to post
Share on other sites

This tip seems to work. I guess it is better to be aware, though I'm still not sure that you do mean that it gets corrupted in some way.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...